the small print informatique & parpaings

26mar/088

mes aventures sous Ubuntu

On va commencer par le truc qui a marché.

Accès à mes disques dur ntfs
Chaque fois que j'accédais à un disque ou une partition windows, je devais rentrer mon mot de passe.
Je me suis penché sur le problème, et maintenant tout marche.

J'ai un disque dur nommé "Nazdrowie".
1. J'ouvre le navigateur de fichier sous Ubuntu, et je vais dans /media.
2. Je crée un repertoire "Nazdrowie" dedans.
3. J'ouvre le terminal et j'écris "sudo fdisk -l" pour voir les disques et les partitions triés par chemin d'accès.
4. Ensuite, dans le même terminal ou un autre, j'écris "blkid" de façon à connaitre l'UUID des disques, leurs noms, leurs types et leurs chemins d'accès
5. les commandes "blkid" et "fdisk -l" vont me permettre de sélectionner les disques à "monter" dans un fichier de configuration. Donc dans un terminal, j'écris "gksu gedit /etc/fstab".

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=3c3f28f5-3985-48d3-a1f3-372d7fc260b5 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda5
UUID=16F87C97F87C7739 /media/sda5     ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda6
UUID=7C1C2F311C2EE63C /media/sda6     ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda7
UUID=ba25fdf3-6a84-4949-ad6f-002fcae3c46f none            swap    sw              0       0
# /dev/sdb3
UUID=b4125c15-6ef0-407d-be11-118a5d5b5e1c /media/sdb3    ext3    defaults,errors=remount-ro    0    1
# /dev/sdb5
UUID=5A34F31534F2F2BD /media/Musique    ntfs    defaults,umask=007,gid=46    0    1
# /dev/sdb6
UUID=B0D86DF8D86DBCEA /media/Libre    ntfs    defaults,umask=007,gid=46    0    1
#/dev/sdc1
UUID=CA78017678016315    /media/Video_DVD    ntfs    defaults,umask=007,gid=46    0    1
#/dev/sdb1
UUID=EA349ADF349AAE57    /media/Nazdrowie    ntfs    defaults,umask=007,gid=46    0    1
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
#/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0

Pour expliquer rapidement, je vais prendre l'exemple de mon disque "Nazdrowie".
J'ai rajouté la ligne commentée "#/dev/sdb1".
La ligne d'en dessous, j'inscris l'UUID du disque récupéré par "blkid", à coté j'écris le chemin d'accès "/media/Nazdrowie", ensuite le type, le charabia de la fin j'ai recopié ce que j'avais pour les autres disques.
Le truc important, à la fin du fichier il faut ajouter un ligne vide (me demandez pas pourquoi).

Hop, 2 petits liens pour fstab :
f3wm.free.fr/linux/fstab.html
www.lea-linux.org/cached/index/Admin-admin_fs-fstab.html

Maintenant, on va passer à ceux qui ne marchent pas plus.
Il y a quelques jours, j'avais réussi à installer les drivers ATI pour Ubuntu. Grande satisfaction quand on voit sur les forums et dans la réalité la merde que c'est pour réaliser cet exploit.
J'avais mon dual-screen et mes effets Compiz activés en même temps. Trop génial les fenêtres qui se déforment quand on les déplacent.
Le problème, c'est que je devais passer par le Centre de Contrôle Catalyst d'ATI pour régler cela.
Et bien sûr à chaque fois que j'allumais l'ordinateur, car cela ne sauvegardait pas les paramètres (c'est assez relou).
Bref ça c'était avant.

Depuis j'ai toujours mon dual-screen (que je configure à chaque boot), et pis c'est tout ! (comme dirait vous savez qui).
Je me suis dis, "c'est pas possible, t'as dû oublier une manip (crucifier un poulet, brûler un chat, manger des salsifis, trouver une info en 5sec sur le site d'orange, etc...).
Donc je recommence (le con !).
Résultat.....j'ai perdu Compiz, je n'ai plus le son (j'ai pas compris pourquoi), et la roulette de ma souris ne fonctionne plus  (et c'est chiant !).
Et j'ai cette #@!!* d'erreur quand je veux recompiler le module :

des problèmes de dépendances empêchent la configuration de fglrx-kernel-2.6.22-14-386 :
 fglrx-kernel-2.6.22-14-386 dépend de xorg-driver-fglrx (= 8.433-1) ; cependant :
  La version de xorg-driver-fglrx sur le système est 8.471-0ubuntu1.

Je m'y étais fait aux fenêtre qui se déforment, ça me manque.
Je ne peux plus écouter mes mp3 ni voir des video youtubesque (pas de pop/rockinfo :'( )

Au fait, "Nazdrowie", ça veut dire "à la tienne" en polonais (quelle belle chute).

12mar/080

Drivers ATI fonctionnels sous Ubuntu 7.10

Enfin ! A un mois de la sortie de la Hardy Heron (Ubuntu 8.04), je suis arrivé à passer en Dual-screen et à activer Compiz.

>>>Dual-Screen

Pour le dual-screen c'est encore assez aléatoire. Je ne passe plus par le menu "Système">"Administration">"Ecrans et affichage", j'utilise le panneau de contrôle ATI dans "Applications">"Accessoires">"ATI Catalyst control Center".

C'est très clair. Le centre de contrôle Catalyst met un peu de temps à se lancer (bien 20 sec).
J'active mon bureau étendue dans les "modes d'affichage" (visible sur l'image). Il est demander de redémarrer ensuite.
Chose que je ne fais pas (plus) actuellement, car au reboot je suis à nouveau en mode "clone". (Déjà je n'attéris pas sur l'écran console d'administration comme cela m'arrivait il y a quelques mois).

>>>Compiz

Les effets visuels de Compiz s'acivent dans le menu "Système">"Préférences">"Apparence"> onglet "Effets visuels"
Une fois là on sélectionne "Normal", "Extra" ou "Personnalisé". J'ai choisi la dernière option (mais là je découvre le mode "Normal" coché....bizarre ?)
A moi le cube 3D qui bouge (que sur mes 2 bureaux, faut que je regarde comment en mettre plusieurs). L'écriture de feu sur l'écran, les fenêtres qui se tordent (effet le plus génial pour moi), la transparence, etc...
C'est impressionnant comme cela respire la légèreté. Il n'y a aucune impression de "lourdeur".
C'est peut-être pour cela que ca tourne sur des configurations plus modeste et même sur des eeepc.
Je suis sûr qu'un tel système d'effets visuels sous Windows aurait été une vraie usine à gaz entrainant saccades, lenteurs, et plantages.

>>>Liens utilisés

Voici ci-dessus la liste des liens utilisés

>>>Carte ATI et version du pilote
Je possède une ATI Radeon X1900GT en pci-express.
Pilotes ATI Catalyst 8.47.3
Feisty Fawn 7.10

7déc/070

Skype beta 2.0.0.24 pour Linux

Version du 5 décembre 2007

25oct/0710

Comment il nous narge sous Compiz/Fusion

Ouiiiiiiiiiiiiiiiiiin. Pourquoi lui et pas moi ?

Enfin, une spécial dédicace à toutes les personnes qui n'arrivent pas à faire fonctionner Compiz+Fusion sous Ubuntu (comme moi).

Ah oui la config de la machine :

XGL + Beryl on UBUNTU Linux (Dapper)
Config:
PII-450 mHz
128 Mb Ram
GeForce MX440 32 Mb RAM

C'est possible ?

23oct/075

Dual screen sous ubuntu. Ubuntu 1 – Glabou 0

Bon ça fait une semaine que je suis sous Ubuntu.
Une semaine que j'ai le même écran sur mes 2 écrans.
Une semaine que je fais des "sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup.x"
Un jour j'y arriverai.

Pour info je suis sous Ubuntu 7.10 et j'ai une ATI x1900GT.

Je ne veux surtout pas passer par "Système>Administration>Ecran et Affichage" car ce truc ne fonctionne pas du tout, mais pas du tout, du tout !

Après une dernière manip, je n'ai plus qu'un écran sur 2 d'allumé. J'arrête pour ce soir, on verra demain.

17oct/073

Install Ubuntu….la suite.

L'install s'est bien passée.
Ca démarre vite. Et c'est fonctionnel une fois dedans (contrairement à windows, qui continue à charger les applications une fois dans windows).
OpenOffice.org 2.3 démarre en 2sec, plus rapide que Word sous windows.
Histoire de rester en contact, j'ai installé Skype et Emessene (ce dernier grâce au billet de Jeremy). Skype fonctionne bien, je regrette juste qu'on ne puisse pas utiliser la webcam. Du coup, j'installerai sûrement VirtualBox pour utiliser Skype avec la webcam sous windows (peux pas faire autrement).
Bon ça c'est pour la partie software.

Ensuite, j'ai voulu m'attaquer au dual screen. C'est là que c'est drôle.

 sudo aticonfig –initial=-head --screen-layout=above

Yes, cool, ça marche ! J'ai deux écrans différents. Bon mon écran principal est à droite. J'essaye d'aller à gauche pour atteindre mon 2e écran. Niet. A droite. Niet. Et c'est là que c'est drôle, pour aller sur mon écran de gauche, faut que j'aille en haut (le "above").
Du coup, j'ose aller dans la config des écrans, je mets "left", j'active et je reboote.
Et là, plus d'affichage, ou mauvaise résolution.
Redemarrage en ligne de commande.
Restauration de l'ancien "xorg.conf.flgrx-0" (après avoir rechercher la commande "renommer" sur la Wii).
Ca fonctionne, je suis revenu en simple screen sur mes deux écrans.

Bref à part ce problème, ça marche bien.
Par contre, pour les novices comme moi sous linux, je pense que c'est bien d'avoir un second PC (ou Mac, ou Wii) sous la main, pour accéder à Internet en cas de problèmes.

25avr/070

Soirée – rien ne marche

Blog inaccessible vers 23h30 :
MySQL Error : 2013 - Lost connection to MySQL server at 'reading initial communication packet', system error: 111
Un petit tour vers le site travaux.ovh.com pour me rendre compte

Bref, ça fonctionne.
-------------------------------------------------------------------------

Ensuite, enfin au même moment, je décide de graver le live cd Ubuntu 7.04 Feisty Fawn et de la tester.
On pense des choses....on ne se rend pas compte.
Après avoir essayer :

  • 4 CD-RW (illisibles)
  • 2 CD-R (que j'ai jeté)
  • un flashage en 1.29 de mon DVR-111D (flash réussi, c'est déjà ça)
  • le tchi-tchi, les poupées péruviennes, et les pattes de lapin

Je suis en train de graver sur un autre CD-RW (j'en ai pas mal) en X4....ok c'est pas rapide, voir très lent, mais pour l'instant ça fonctionne.
Si ça marche, rendez-vous en fin de soirée ou demain, pour un test d'avant-gôut de la dernière version d'Ubuntu.

Page 4 sur 41234